SmartTerminal Isolated Errors but Website Up

Incident Report for PayJunction

Resolved

All systems fully operational:
- Upstream providers have fully repaired the Impacted fiber lines
- Additional routes also available to prevent future problems

This incident has been resolved.
Posted Sep 03, 2026 - 14:19 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2026 - 15:00 UTC

Update

All systems are operational. We will continue to monitor the situation.
Posted Sep 02, 2026 - 14:49 UTC

Update

We have successfully re-routed major portions of traffic around a major fiber optic cut.

Traffic SHOULD START RESUMING while we work with upstream providers to restore full connectivity.

YOU MAY RETRY your SmartTerminals transactions; we see successful transaction flow has resumed.

==
If your SmartTerminal still does not work, PLEASE REBOOT your SmartTerminal.
==

( We anticipate the the original root cause of a fiber cut to take a while for full repair; we will update this status page here ).
Posted Sep 02, 2026 - 14:46 UTC

Update

We have successfully re-routed major portions of traffic around a major fiber optic cut.

Traffic should start to resume while we work with upstream providers to restore full connectivity. We anticipate the fiber cut taking a while to repair.
Posted Sep 02, 2026 - 14:46 UTC

Update

We are currently experiencing partial SmartTerminal connectivity outages due to a network routing problem caused by a cut a fiber optic line with an upstream network provider.

Some customer SmartTerminal transactions are processing normally, while others may receive network connectivity errors.

All other PayJunction services are up, and remain available,
Again All other PayJunction services are up, and remain available,
including our website Virtual Terminal and software API processing.
While we restore SmartTerminal connectivity, you may continue processing transactions by entering the card information directly into the Virtual Terminal or your connected software.

Our engineering team is actively rerouting traffic through alternate data centers and network providers. We apologize for the disruption and will provide updates as service is restored.
Posted Sep 02, 2026 - 14:23 UTC

Identified

We have identified an issue impacting our SmartTerminals. This may result in delays or the inability to process transactions using the SmartTerminal; however, you may continue to process transactions using our PayJunction virtual terminal by using your web browser to log directly into our website.

Our engineering teams are engaged and attempting to reroute our SmartTerminal traffic to alternate datacenters and/or network providers.

We will continue to monitor and restore services.

Updates will be posted as more information becomes available.
Posted Sep 02, 2026 - 14:02 UTC
This incident affected: Smart Terminals.