Impacted services have been fully restored, but we continue to monitor the situation.
Any further updates will be posted if more information becomes available, otherwise we anticipate closing this incident shortly.
Posted Jun 14, 2026 - 08:36 UTC
Identified
We have identified an issue with one of our network bandwidth providers. This may result in the inability to connect to certain web pages, API endpoints, or the ability to process transactions.
Our engineering teams are engaged and attempting to reroute traffic to restore network connectivity through a multitude of our backup network providers.
We will continue to monitor and restore services.
Updates will be posted as more information becomes available.
Posted Jun 14, 2026 - 08:16 UTC
This incident affected: Web Based Transactions (Virtual Terminal, API, etc), Processors, Smart Terminals, and No-code Payments Integration.